4k 威武

今天从 delectate 同学的博客上下载了一个他从 youtube 下载的 4k 视频,下面是他播放时的效果:

因为很感兴趣,所以从youtube把视频下载了下来,没想到 4096 x 2304 (16:9)把我卡的啊……先是用mplayer file播放,默认xv输出器,直接崩溃,提示fatal error。使用mplayer -vo x11 file播放,卡死,彻彻底底卡死……x差点崩溃。强退后发现compiz,metacity已经崩溃了。 我用 vaapi 硬解码的 mplayer 播放了一下,果然可怕, CPU 占用率飙高,就算开了跳帧也严重卡,而且影音不同步,播放的时候看到 mplayer 也出现了各种问题,我贴出来各位参考一下:

$ mplayer '/home/wheat0r/下载/Life_in_the_Garden_4k_resolution.mp4' -framedrop
MPlayer SVN-r31303-4.4.3 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/wheat0r/下载/Life_in_the_Garden_4k_resolution.mp4.
libavformat file format detected.
[lavf] stream 0: audio (aac), -aid 0, -alang und
[lavf] stream 1: video (h264), -vid 0
VIDEO:  [H264]  4096x2304  24bpp  23.976 fps  6445.1 kbps (786.8 kbyte/s)
Clip info:
major_brand: mp42
minor_version: 0
compatible_brands: isomavc1mp42
libva: libva version 0.31.0-sds6
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/va/drivers/nvidia_drv_video.so
libva: va_openDriver() returns 0
Couldn't open video filter 'ass'.
ASS: cannot add video filter
[ass] Init

[ass] Updating font cache

Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VA API accelerated codec.

Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)

==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
AUDIO: 48000 Hz, 2 ch, s16le, 119.2 kbit/7.76% (ratio: 14897->192000)

Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))

AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Unsupported PixelFormat 61
[VD_FFMPEG] Trying pixfmt=1.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vaapi] 4096x2304 => 4096x2304 H.264 VA-API Acceleration  [zoom]
[ASPECT] Warning: No suitable new res found!
[vo_vaapi] Using 1:1 VA surface mapping
[vo_vaapi] vaCreateContext(): resolution not supported
FATAL: Cannot initialize video driver.
Unsupported PixelFormat 61
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat 61
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
[VD_FFMPEG] Trying pixfmt=2.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vaapi] 4096x2304 => 4096x2304 Planar YV12  [zoom]
[ASPECT] Warning: No suitable new res found!
A:   3.0 V:   0.4 A-V:  2.628 ct:  0.021   0/  0 ??% ??% ??,?% 50 0

**** Your system is too SLOW to play this!  ****

Possible reasons, problems, workarounds:
- Most common: broken/buggy audio driver
- Try -ao sdl or use the OSS emulation of ALSA.
- Experiment with different values for -autosync, 30 is a good start.
- Slow video output
- Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
- Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
- Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
- Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
- Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

A:  16.8 V:  16.7 A-V:  0.105 ct:  0.021   0/  0 77% 25%  0.8% 262 0
Exiting... (Quit)

6 thoughts on “4k 威武

  1. moja

    我也试了下~ 资源占用是很高…… 刚开始是原尺寸播放的~ 可惜屏幕不够大…… 不过和后来 fit to screen 的占用一样多…… 不过那个4k分辨率的视频质量确实不够高~ 要是质量再高的话占用资源还会高的~ QuickTime 是神器~
    直接放 twitpic 上了~ http://www.twitpic.com/24pu1u
    p.s. /home/wheat0r/下载/ <— 中文自重

    Reply

Leave a Reply